【自己解決しました。】PDFビルダーで「登録」ボタンを押下するとVBのnullエラーになる

「ASTERIA WARP」「ASTERIA 3」「ASTERIA On Demand」の
インストール・動作環境・パイプライン機能・フロー機能など全般について

【自己解決しました。】PDFビルダーで「登録」ボタンを押下するとVBのnullエラーになる

投稿記事by Dwatanabe » 2018年6月18日(月) 17:49

表題の件で、相談です。
以下の環境下で作業しています。

★環境
OS: Windows XP Pro ver2002 SP3
フローデザイナ: 4.9.0.9199
Office: Microsoft Office Professional Plus 2010 ver 14.0.6129.5000 (32bit)

上記環境下で、フローデザイナにPDFビルダーを配備し、
コンポーネントをダブルクリックしてExcel越しにPDFビルダーを操作しています。
なおExcelを開く際に、「マクロを有効にしますか?」と問われるので、「マクロを有効にする」を選択しています。

このあと、Excelのタブに「Flow Designer」があるのでクリックし、
タブ内の「PDF Builder」をクリックして、PDFBuilderを起動しました。
※Infoteria PDFBuilder V1.3.0 です。

ここから、必要な設定をもろもろ行い、
「登録」ボタンを押下するのですが、一瞬で以下のエラーメッセージが出てしまい、登録処理が成功しません。

「Microsoft Visual Basic
実行時エラー '94':
Nullの使い方が不正です。」

ためしに、
全く新規のフローにPDFビルダーのコンポーネントを配備して、
最低限の設定値を入れたうえで「登録」ボタンを押下してみましたが、
こちらもエラーになります。

同じ境遇に遭われた方いませんか?
または、回避案をお持ちの方がいたら教えていただけませんか?

登録処理が出来ないと何もできないので、大変困ってます。。。
最後に編集したユーザー Dwatanabe [ 2018年6月19日(火) 14:58 ], 累計 1 回
Dwatanabe
 
記事: 2
登録日時: 2018年6月18日(月) 17:39

Re: PDFビルダーで「登録」ボタンを押下するとVBのnullエラーになる

投稿記事by Dwatanabe » 2018年6月19日(火) 14:57

本件、自己解決しました。

とあるセルに埋め込んだ以下の文字列が、原因不明の悪さをしていました。

"[興行名2]"

この文字列を消して「PDFBuilder」で「登録」ボタンを押下したところ、
エラーなく登録処理が完了しました。

そのあと、

全く同じセルに、全く同じ文字列"[興行名2]"を入力し、Excel保存→「PDFBuilder」で「登録」ボタンを押下したら、
これも登録に成功しました。

その後は、問題も発生せずに快調に使えています。

謎の現象ですね。。。

同じExcelシートには、他にも"[*****]"というフォーマットでいくつか文字列を埋め込んでいるのですが、
なぜ"[興行名2]"だけがエラーになり、
しかもセルから文字列を消して、再度同じ文字列を入力し直したら上手く行ったのか、分かりませんでした。

同じ現象に合われた方がもしいたら、
テンプレートにしているExcelファイルに入力した文字列を削除し、再入力後にお試しいただければと思います。
Dwatanabe
 
記事: 2
登録日時: 2018年6月18日(月) 17:39


Return to 聞きたい、知りたい、教えます

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[0人]

cron